Symptoms
- In 2018, eVetPractice users reported multiple instances where Dymo label printers were delaying label printing by 10 to 15 seconds with each label print.
Cause
- See https://developers.dymo.com/2018/04/24/recent-issues-with-slow-printing/ for a full technical breakdown.
Resolution
- Update your workstation to the latest version of the DLS, which can be downloaded here:
- https://evetpractice.blob.core.windows.net/installs/DLS8Setup8.7.4.exe
It is recommended that a reboot of the PC be done to make sure that the Dymo WebService application is started.